Overview - Calculation Manager

This tool allows you to organize and manipulate calculations in Ecce. By invoking other tools from the Calculation Manager, you can plan, submit, and monitor a large number of calculations, as well as examine and manipulate the results.

The Calculation Manager window depicts calculations within projects, much as the Microsoft Windows Explorer depicts files within folders on a personal computer. A project is a container that may include calculations and other projects. A calculation represents a single computational run (including restarts).

The Calculation Manager window is split into three panes. The left pane displays the project tree. The right pane or project workspace lists the contents of the current project (the project selected in the project tree). The bottom pane or message area displays information about current operations.

Selecting a calculation in the Calculation Manager provides a means to manipulate the parameters and results of that calculation. When the Calculation Manager is opened and displays the last-used project area, the project tree automatically scrolls the project into view in the tree.

Names of projects displayed above the message area show the name of the data server in URL format rather than just the path to the calculation.

Key Concepts:

Starting the Calculation Manager

Calculation Manager in the Ecce Gateway

Click on the Calculation Manager icon in the Ecce Gateway. If the Calculation Manager is already running, this will bring its window to the front. To start a separate instance of the Calculation Manager in a separate window, shift-click on the icon.

The following items briefly describe elements of the Calculation Manager window.

Toolbar

The Calculation Manager's optional toolbar provides one-click editing and movement around the project tree. To show/hide the toolbar, use the Option menu's Show Toolbar option.

Editing Buttons
Copy button Copy the currently selected calculation or project
Paste button Paste a copied calculation or project into the currently selected folder
Delete button Delete the currently selected calculation or project
Back button

Interrupt the current Copy/Paste/Delete/Navigation operation--helpful if the server hangs or if you change your mind during a long operation such as copying a large project hierarchy. The stop sign icon turns red when one of these server operations is under way. Otherwise the Interrupt button is inactive (grayed out).

Note: When you click the Interrupt button, Ecce stops waiting for the server operation to complete. This does not necessarily cancel the operation on the server. The actual result depends on the operation that was interrupted. For example:
Interrupt... Result
...deleting a large project hierarchy Some files will be deleted while others won't.
...copying a large project hierarchy Some files will be copied while others won't.
...opening a large project hierarchy The project will not be opened.
...finding projects or calculations (below) The Find operation is canceled.
Project Tree Navigation Buttons
Back button Find project or calculation name(s) that contains a specified case-sensitive string of characters (same as the Find option on the Calculation menu). This prototype searching capability can be slow when performed over many projects and calculations. To cancel a Find operation, use the Interrupt button.
Back button Back to the previously selected project--helpful when you switch between projects that are widely separated in the project tree
Up button Up one level in the project tree from the currently selected folder
Forward button Forward to a previously selected project (after using the Back button)

Project Tree and Workspace

The project tree (left pane) of the Calculation Manager window shows a hierarchy of folders that represent projects or collections of projects. You always have access to projects stored in the "share" folder or in your own folder, which is located within the "user" folder. Access to other project folders may require additional authentication.

A single calculation can be moved by dragging it to a destination project folder in the tree view. The Calculation Manager supports copy-and-paste or drag-and-drop operations across data servers or authentication realms. This is useful to move data from one server to another (for sites using multiple data servers) or to copy data to the share area for others to view.

The project workspace (right pane) of the window lists the contents of the folder selected in the project tree. To show the contents of a project folder, click on the project name or folder icon Project folder icon in the project tree—or double-click on the project name or icon in the right pane.

When the selected project contains calculations, the workspace lists each calculation by name in a table of calculation properties with other descriptors such as the "Creation Date" and the "Application" (computational code).

How to...   Manage Projects and Calculations

Icons in the workspace indicate the "Type" of item and some other calculation properties.

Descriptor Icons What the Icons Mean
Type Project icon Project folder for containing calculations and subprojects
Ecce icon Ecce calculation (not associated with an application)
Gaussian icon Amica calculation
Gaussian icon Gaussian calculation
NWChem icon NWChem calculation
State Created state iconReady state iconSubmitted state icon
Running state iconCompleted state iconImported state icon
Killed state iconIncomplete state iconMonitor Error state icon
System Error state icon
Calculation run state icons indicate (by their shape and color) the preparation or processing state of Ecce calculations--such as "created" or "running" or "completed."
See... Legend of Calculation Run States
Reviewed Checkmark icon Check mark in the Reviewed column indicates that the calculation has been reviewed in the Calculation Viewer.
Annotation
or
Citation
Checkmark icon Check mark for these properties indicates that an annotation or citation has been created for the calculation.

You can customize the appearance of the workspace to suit your purpose:

How to... Display Calculation Properties
  Customize the Calculation Manager Display

Menu Bar

Each of the menus on the menu bar can be "torn off" as an independent window that remains visible while you work. To "tear-off" a menu, open the menu by clicking on the menu title and then choose the dashed line that separates the menu title from the menu options.
Tip: Open any menu from the keyboard by using the Alt+underlined letter combination (for example, Alt+h opens the Help menu). Then select a menu option by pressing the letter that corresponds to the option.

- Calculation Menu

The Calculation menu enables you to create, import, and delete calculations as well as create and delete projects.

New Calculation Create a new calculation within the currently selected project. If no project is selected, this option will appear disabled on the menu.
New Project Create a new project folder for containing calculations or other new subprojects. The new project appears as a folder in the current project workspace.
Import Calculation Import a previously run calculation that was generated outside of the Ecce user interface.
Delete Delete the selected project or calculation (and all associated files and directories) from the project tree and workspace.
Find Find project or calculation name(s) that contains a specified case-sensitive string of characters. This prototype searching capability can be slow when performed over many projects and calculations. To cancel a Find operation, use the Interrupt button.
Quit Close the Calculation Manager window.
Tip: To end an Ecce session and close all tool windows at once, close the Gateway.

- Edit Menu

The Edit menu enables you to perform various cut and paste operations on the item currently selected in the project workspace of the Calculation Manager window.

Duplicate Make a duplicate of a project or calculation and place it at the same level in the project tree as the original item. The Duplicate operation reproduces the input files of calculations but NOT the output files of any finished calculations: if a project contains finished calculations, the duplicated project will contain similar calculations that are ready to run.
Note: The Duplicate operation is functionally the same as a Copy/Paste operation (below) except that Copy/Paste allows you to place the new project or calculation anywhere in the project tree.
Duplicate Setup with Last Geometry Duplicate the inputs of a completed geometry optimization calculation (as above), but use the chemical system geometry from the final step of the selected calculation.
Note: If the selected calculation is not completed geometry optimization, you may see a warning in the message area. The duplicated calculation would be the same as it would be after the Duplicate operation.
Copy Copy a project or calculation into the cut/paste buffer for pasting into another project.
Paste Insert a copied item into the currently selected project.
Annotation... Bring up the UNIX default editor in order to enter/edit/view text in a special file that is associated with a given project or calculation. This Annotation option is the only way to access this information. The only way to remove an annotation is to delete all annotation text.
Citation... Bring up the UNIX default editor in order to enter/edit/view a literature citation that is associated with the selected item. The only way to remove a citation is to delete all citation text.
Preferences... Open the Preferences window for customizing the appearance and operation of the Calculation Manager. Options include the selection and order of calculation properties displayed and the formats for date and time. Use the Access Control tab to selectively grant read or read-write access to other users for project data you own. By default only the owner of the data has read-write access. The access permissions you set remain in effect until you change them.

- Options Menu

The menu includes items for controlling how the tree hierarchy is sorted along with some display and operating options previously found within the Calculation Manager's Preferences window. Click on a toggle button to turn the option on icon toggle on or off icon toggle off.

Change Access Control...

Open the Access Control dialog window to specify which Ecce users may have access to the contents of your project folders. You may grant access only to project folders that you have created. This window contains two fields for entering user names to grant access to the project folder that is currently open and displayed in the Calculation Manager: one field for "read-only" access and one field for "read/write" access.

To grant access to all Ecce users, enter the keyword ALL instead of specific user names. To deny access to a project, just leave the fields blank.

Picture... Access Control Window
Sort Tree by> Sort the project tree by Name, Name (in reverse), Date, Date (in reverse), None (no sort order).
Confirm Deletes Mark this option to see a confirmation dialog each time you delete projects or calculations.
Confirm Resets Mark this option to see a confirmation dialog each time you reset a calculation.
Show Toolbar Mark this option to show the Calculation Manager's option tool bar of editing and navigation buttons--including an Interrupt button for interrupting server operations that are unexpectedly long.
More about... Calculation Manager Tool Bar
Show Run State Legend Mark this option to show the legend of calculation run state icons across the middle of the Calculation Manager:
Legend icon createdLegend icon readyLegend icon submittedLegend icon running
Legend icon completedLegend icon importedLegend icon killedLegend icon incompleteLegend icon monitor errorLegend icon system error
More about... Legend of Calculation Run States
Use Fixed "Type" and "Name" Columns Mark this option to maintain the Type and Name columns at a fixed position on the left side of the properties table in the Calculation Manager.

 

- Run Mgmt Menu

The Run Management menu provides options for monitoring or halting the progress of a running calculation, resetting a calculation for a modifed run, and cleaning up files created by the calculation.

tail -f  on Output File... Open an xterm window that shows the contents of the output file for the selected calculation so that you can monitor its progress in real time as it runs. The output file scrolls in the window as the calculation runs.
shell in Calculation Run Directory... Open an xterm window into the scratch directory (on the machine that is running the calculation) where Ecce stores temporary files during processing. With the proper knowledge of UNIX and the computational code, you can monitor what is happening.
Manage Files... Opens a window which shows a list of the files on either the Ecce data server or the compute server. You can View or Remove files at either location, or Copy specific files from the compute server to the Ecce data server.
Terminate Calculation Kill a submitted or running calculation--or abort a calculation import in progress. Ecce may take half a minute to confirm that the job is terminated and display the killed (coffin) icon for that calculation.
Check Job Monitoring Check whether job monitoring has failed for any calculations in the currently displayed folder. This detects errors that could not be caught by the monitoring process and reports them in the message area. Use this option if calculations seem to be hung in the submitted Submitted state icon or running Running state icon states.
Reconnect Job Monitoring Re-establish the job monitoring process for a submitted or running calculation so that information displayed in the Calculation Manager is updated correctly. Use this option when job monitoring terminates before your calculation completes, which is usually indicated by the Monitor Error icon Monitor Error state icon for the calculation.
Reset to Rerun Reset the selected calculation to the "ready" state and delete any data associated with previous runs, including all output properties and files on the run machine.
Reset for Restart Reset the selected calculation to the "ready" state so that it can be restarted from Ecce. (Only the Ecce calculation state is changed. No chemical system properties or output files are deleted, and the input file remains the same.) After selecting "Reset for Restart" and before launching the calculation again, you must manually edit the calculation input file, specifying whatever "restart" keyword and supporting inputs are necessary for the current code.)
Warning: If you do not modify the input file before launching a calculation that has been "reset for restart," then the calculation will begin again from the original starting geometry. This would pile a repeat set of properties on top of the ones already present for the calculation in Ecce's data server--you don't want that!
Reset State> Set the selected calculation to one of these run states:
Reset to completed Completed state icon Processing is complete.
Reset to incomplete Incomplete state icon Processing did not complete successfully.
Reset to imported Imported state icon Calculation results were imported from an external source.
Reset to killed Killed state icon Processing was canceled (coffin icon).
These options enable you to set the state of a calculation that may have been incorrectly reported because of network or machine instability.

Mark as Reviewed
or
Mark as Unreviewed

Manually specify a selected calculation as either "reviewed" or "unreviewed" in the Calculation Viewer. Any calculation that has been opened and reviewed in the Calculation Viewer is automatically marked as reviewed.
How to... Visually track which calculations have been reviewed
Cleanup Run Directory Files Remove both the calculation and scratch directories from the machine where the selected calculation was run.
It is good practice clean up these directories to conserve disk space on the machines where the calculations are run.
View Run Log... Open a window that shows a log of messages generated by the system during the calculation processing--sometimes a useful tool for "debugging" a run. Run logs are in XML (extended markup language) format.

- Tools Menu

The Tools menu provides access to a variety of tools that can operate on calculations.

Builder... Start the chemical system Builder tool using the chemical system from the currently selected calculation. (Or if the chemical system is not yet specified for the calculation, use the Builder to create or choose a chemical system.)
Calculation Editor... > Start the default Calculation Editor tool for editing inputs to the currently selected calculation--or open a specific Calculation Editor from a submenu of computational code options:
NWChem... Open the NWChem Editor.
Gaussian-98... Open the Gaussian-98 Editor.
Amica... Open the Amica Editor.
If the calculation is NOT yet associated with a specific code, the Calculation Editor opens in the context of the chosen computational code and displays parameter options specific to that code.
If the calculation IS aready associated with a different code, Ecce first prompts to confirm whether to change the code for the calculation. Calculations that are in a read-only state (such as submitted, running, or completed calculations) are not switchable between computational codes.
Basis Set Tool...

Start the Basis Set tool for assistance in specifying a basis set for the currently selected calculation.

 

Job Launcher... Start the Job Launcher tool for submitting a ready calculation to a computer for processing.
Calculation Viewer... Start the Calculation Viewer tool for the currently selected calculation. This tool summarizes all information for a calculation and can display graphic visualizations of such things as the chemical system, molecular orbitals, or a set of vibrational normal modes.
View Input File... View the contents of the input file for the currently selected calculation.
View Output File... View the contents of the output file for the currently selected (and completed) calculation.

- Help Menu

The Help menu provides access to this online help and enables you to supply feedback about your experience with Ecce.
Help on this tool Show online help information for this tool or window.
Support Display a form for providing support requests to your onsite Ecce representative or adminstrator about problems, questions, or other comments.
Note: Although your onsite Ecce administrator should be your first choice for problems and questions, you may address feedback or suggestions to the Ecce development team at ecce-support@emsl.pnl.gov.

Legend of Calculation Run States

Legend icon createdLegend icon readyLegend icon submittedLegend icon runningLegend icon completedLegend icon importedLegend icon killedLegend icon incompleteLegend icon monitor errorLegend icon system error

Each calculation within a project in the Calculation Manager can be marked by a small colored icon that indicates the state of the calculation by the icon color and shape. The legend shows the icons associated with each of the nine possible calculation run states. You can hide the legend by opening the Options menu and unmarking Show Run State Legend.

The nine calculation states are defined as follows:

Created Created state icon Calculation is in preparation and has been saved on Ecce's data server.
Ready Ready state icon Calculation is defined and ready for submission to a machine.
Submitted Submitted state icon Calculation has been submitted for processing on a machine.
Running Running state icon Calculation is currently being processed on the designated machine.
Completed Completed state icon Processing is complete.
Imported Imported state icon Calculation results were imported from an external source such as the code output results of a calculation processed outside of Ecce.
Killed Killed state icon Processing has been canceled (coffin icon).
See also ... Terminate Calculation in the Run Mgmt menu.
Incomplete Incomplete state icon Processing did not complete successfully.
Monitor Error Monitor error icon Calculation monitoring has failed or encountered errors after 25 attempts to restart and continue monitoring. When a calculation has this state, open the Run Mgmt menu and use View Run Log to identify the problem by scanning for an error at the end of the run log.
System Error System Error state icon Job has failed during monitoring due to the current status of the machine (such as a machine being taken off the network for maintenance).

The colors shown here are the Ecce default colors. You can modify these run state colors for your own use by using the Preferences option from the Ecce Gateway.

How to... Set Color Preferences

Window Footer

At the bottom of the window is a footer that displays the following status information:

More about... Items in the Ecce Window Footer.

Ecce Online Help
Revised: May 5, 2004
Disclaimer