Manage Projects and Calculations

To select an item (project or calculation) for most of the following operations, click on its name in the right side of the Calculation Manager window.

Create a New Project

  1. Click on (select) a folder name in the project tree, such as the folder with your user name.

  2. From the Calculation menu, choose New Project.

    The new project appears in the right pane, within the selected folder. The new project is labeled as "Project" or "Project_#" until you rename it.

Create a New Calculation

  1. Click in the project tree on the project folder name where you want to create the new calculation.

  2. From the Calculation menu, choose New Calculation.

    The new calculation with the "created" state appears in the right pane, within the selected folder. The new calculation is labeled "Calc" or "Calc_#" until you rename it.

For an overview of setting up a new calculation (with a chemical system, calculation methods, and computing platform), see the example, "Setting Up and Running a Calculation."

Rename a Project or Calculation

  1. In the project tree, click once on the folder/project name to select the folder; then click again to select the entire name.
    In the project workspace, double-click on either a folder/project or calculation name to select the entire name.

  2. Type to replace the name, or click on the name again to position the insertion point and edit the name.
Disallowed characters -- Ecce does NOT accept the following keyboard characters in a project or calculation name:
space   tab   /   '   :   $   ~

Import a Calculation Created Outside Ecce

  1. Click on the project to which you want to import a calculation.

  2. From the Calculation menu, choose Import Calculation.

    In the resulting Import Calculation window, directory and file lists and a filter field enable you to identify and select the calculation file that you want to import.
    Picture... Import Calculation Window

  3. Select the calculation file that you want to import.

    Note: If you want to import a calculation that was previously run in Ecce, the output files to import are named ecce.out (for NWChem) or g94.out (for Gaussian 94) or g98.out (for Gaussian 98) or amica.out (for Amica). The corresponding imported calculations will be named NWChem, Gaussian94, Gaussian98, or Amica with a unique extension, as needed. Calculation output files are stored below the /Ecce subdirectory of your home account on the machine you used to launch the calculation.

  4. Click OK to import the calculation.

    The imported calculation name will be based on the calculation file name (without extension). Calculations with 1000+ basis functions can be imported in a minute or two, depending on system and network configuraitons.

    To abort a calculation import in progress: from the Run Mgmt menu, choose Terminate Calculation.

Delete a Project or Calculation

To delete a project or calculation that you have created:

  1. Click on the project or calculation to select it in the project workspace.

  2. From the File menu, choose Delete (or use )

    This deletes all files and directories associated with the project or calculation with no option to undelete. If you have delete confirmations switched on (Options menu / Confirm Deletes), Ecce asks you to confirm your decision before deleting.

Reset the Run State of a Calculation

If the run state of a calculation is incorrectly reported in Ecce, you can manually reset the calculation to one of these run states:

Reset to    completed
Processing is complete.
incomplete Processing did not complete successfully.
imported Calculation results were imported from an external source.
killed Processing was canceled (coffin icon).
  1. Click on the calculation that you want to reset.

  2. From the Run Mgmt menu, choose Reset State>.

  3. From the resulting menu, choose Reset to completed, incomplete, imported, or killed.

Copy/Paste/Duplicate a Project or Calculation

Copy (on the Edit menu) means to take a snapshot of a project or calculation so that you can paste it into another project. By default, the name of the new project or calculation is the same as the name of the original item, possibly with a distinguishing number "_#" appended to it, such as H2O_1. The copied project does NOT include calculation output files. If a project contains finished calculations, the copied project will contain similar calculations that are ready to run.

To copy a project or calculation from one project to another:

  1. Click on the project or calculation name to select it.
  2. From the Edit menu, choose Copy.
  3. Click on the name of the target project.
  4. From the Edit menu, choose Paste.
Tip: To copy a project folder to another folder in the project tree, hold down the Ctrl key and use the middle mouse button (Ctrl + ) to drag and drop from one folder to another. You must have appropriate access permissions for either folder.

Duplicate means to reproduce a selected project or calculation, placing it into the same folder where the selected item resides. The duplicated item is automatically inserted after the original and is given the same name as the original with a number "_#" appended. The only difference between the Duplicate and the Copy/Paste operations is that Copy/Paste allows you to place the new project or calculation anywhere you wish.

To duplicate a project or calculation:

  1. Click on the project or calculation name to select it.
  2. From the Edit menu, choose Duplicate (or Duplicate Setup with last Geometry).

Duplicate with last Geometry means the same as Duplicate (above) except 1) if the selected item is a completed geometry optimization calculation, then 2) the inputs of the new calculation will include the final chemical system geometry from the completed calculation. When a project is selected, this option is disabled (grayed out).

Note: If the selected calculation is not a completed geometry optimization, you may see a warning in the message area. The duplicated calculation would be the same as it would be after the Duplicate operation.

Move a Project or Calculation

The Calculation Manager supports copy-and-paste or drag-and-drop operations across data servers or authentication realms. This is useful to move data from one server to another (for sites using multiple data servers) or to copy data to the share area for others to view.

To move a project folder or calculation :

You can move projects and calculations between folders where you have appropriate access permissions: your own user folders, the "share" folder on the Ecce data server, and the folders of other Ecce users who have granted access to you.You can authorize specific users to have access to specific project folders that you own. (See Access Control in the Calculation Manager Preferences.)

Drag Calculations to Other Tools

You can use Ecce`s drag & drop capability to transfer some calculation information between Ecce tools. For example, you can drag a calculation from the Calculation Manager to the Basis Set Tool (for choosing basis sets for that calculation) or to the Builder (for visualizing the calculation's chemical system).

To drag a calculation:

  1. Place the mouse cursor over a calculation name in the Calculation Manager's project workspace.

  2. Press and hold down the middle mouse button. Then move the mouse to drag the calculation information.

    Cursor Examples

    You will see the "move"cursor as you drag. The appearance of the cursor may differ, depending on the graphic interface of your system.

  3. Position the cursor over the drop site (below) in the lower right corner of the other tool window.

    If the tool can accept the information, the drop site arrow turns green when the "move" cursor is over the drop site.

  4. Release the middle mouse button to "drop" the calculation information into the other tool.

    The information actually loaded into the other tool depends on which tool it is. For example, the Builder loads only the chemical system information while the Calculation Editor loads all available calculation input information.

View-Delete-Copy Calculation Files

Use the Manage Files window to directly view, delete, and copy specific files associated with a selected calculation. This capability can be useful, for example, if there were a problem with Ecce's normal process for copying the output files of a calculation from the calculation directory on the compute server back to the Ecce project directory on the Ecce data server.

  1. In the Calculation Manager's workspace, select the calculation whose files you wish to manage.

  2. From the Calculation Manager's Calculation menu, choose Manage Files.
    The resulting File Management window enables you to deal directly with the files associated with the selected calculation.
    Picture... File Management Window

    You can view and manage selected calculation files in two locations:
    File Locations Calculation Files
    Ecce Data Server output files, including results and Ecce logs
    Compute Server
    (where the calculation was run)
    complete job setup information and output files

  3. Select single files (), additional files (Ctrl+), or a range of files (Shift+).
    You may view files only one at a time.

  4. Click on a button to manage the selected files.
    Active Button File Operation
    View the contents of a selected file.
    Delete the selected file(s)
    Copy the selected file(s) from the Compute Server to the Ecce Data Server.

Annotate a Project or Calculation

  1. Click on the project or calculation to select it.
  2. From the Edit menu, choose Annotation.

    This starts your default editor in order to add/edit/view text in a special file that is associated with a given project or calculation. The Annotation option is the only way to access this information.

To remove an annotation: delete all the annotation text.

To see whether calculations have annotations, use Edit / Preferences to show the Annotations column in the project workspace: a checkmark in the column indicates an annotation for the corresponding calculation.

Specify a Citation for a Project or Calculation

  1. Click on the project or calculation to select it.
  2. From the Edit menu, choose Citation.

    This starts your default editor in order to add/edit/view a literature citation that is associated with the selected item.

To remove a citation: delete all the citation text.

To see whether calculations have annotations, use Edit / Preferences to show the Citations column in the project workspace: a checkmark in the column indicates a citation for the corresponding calculation.


Ecce Online Help
Revised: April 29, 2003
Disclaimer