Get Started - The Ecce Gateway

If you are unfamiliar with using Ecce software and want to know how to begin, then you are in the right place.

On the other hand, if you are looking for... ...then try these topics:
how to use Ecce tools to set up and run a calculation Setting Up and Running a Calculation
basic conventions for interacting with Ecce Conventions for Using Ecce
how to register to be an Ecce user Ecce registration Go to Ecce Registration  outside of Ecce Help
what Ecce is and what it does for you What is Ecce?

Starting and Quitting the Gateway

To start Ecce:

  1. Type the command ecce (all lowercase) at the UNIX or LINUX terminal prompt.
    Ecce will prompt you for a password:

    First-time Ecce users:
    1. A message will display asking you to create an Ecce password.
    2. Click OK. The Ecce Password window will display.
    3. Type a password that you will use to log in to Ecce. This can be any string of alphanumeric characters, including spaces, but must be at least 4 characters long.
    4. Click the OK button. A confirm new password dialog will display.
    5. Click the OK button. Depending upon whether Ecce support for automatic data server account creation is enabled at your site, another dialog may request password authentication for the Ecce Web server (example shown here).

    6. Enter your user name and Ecce data server password (obtained from the administrator of the Ecce Web database server at your location) and click the OK button.
      This authentication to the server is a one-time task.
      Note: You may see similar requests for password authentication when you use other Ecce tools to access data other than your own or data on a different Web server. If you need to check your data server password, click the Lookup button after first typing in your ecce password. The Lookup Data Server Password window will display your data server password. This is especially useful if you need to run on two hosts that don't share a common shared file system home directory.

  2. Enter your Ecce password and click the OK button.

    This opens the Ecce Gateway:

    Ecce Gateway

The Gateway is a toolbar that gives you central access to key Ecce tools for creating, managing, and examining computational chemistry calculations. The Gateway is the first tool that you will interact with when you start Ecce.

Note: Most mouse point-and-click interactions in Ecce use the left mouse button .  Use the left mouse button unless specified otherwise.

To quit an Ecce session (and close all Ecce tool windows):

  1. Open the general window control menu: using the mouse, click on the menu button in the upper left corner of the Gateway. If you are using a window manager which does not display a menu button, click anywhere on the Ecce wave icon or on the exit label below it.

  2. From the resulting menu choose Close (or Quit) or press Alt+F4.

    Ecce asks for confirmation:

  3. Choose Yes to end the Ecce session.
    Tip: To close an individual Ecce tool window double-click on the menu button in the upper left corner of the tool window (or single-click and choose Close from the resulting menu).

    If you have unsaved work that is in progress and critical to the definition of a calculation, Ecce will ask whether you want to save your work before quitting. The Job Launcher will not exit when you quit Ecce from the Gateway while a job is currently being launched. It will immediately exit when it is safe to do so after the job launch is done and monitoring has been started.

Using Tools from the Ecce Gateway

Start an Ecce tool by clicking on the corresponding tool icon in the Gateway. An appropriate tool to begin with is the Calculation Manager--Ecce's "master" tool. From the Calculation Manager you can create calculations and call on other tools to plan, launch, and monitor a large number of calculations, as well as examine and manipulate the results.

Tip: To start more than one instance of a tool, shift-click on the Gateway tool icon when the tool is already open.
Click on the tool icon with the right mouse button . From the resulting pop-up menu, choose New.
Tip: To bring the Gateway to the front when it is hidden by other windows, first right-click on the message area in the footer of most Ecce tool windows. From the resulting pop-up menu, choose Show Gateway.
Tip: The Ecce wave animates whenever you start a tool from the Gateway. To stop the animation, click on the wave icon. The animation will stop without causing you to exit Ecce. This feature also enables you to stop a runaway animation if the tool fails to come up for any reason.
How to... Access Ecce Tools
  Manage Ecce Tools on the Desktop
More about... Items in the Ecce Window Footer

Summary of Gateway Tools

The online help overview of each tool is accessible from the Help Contents page--or just click on the corresponding tool icon in the following table. Some Ecce tools are not available directly from the Gateway but rather are available within the tools started from the Gateway. For similar descriptions of all Ecce tools, see the Ecce Tool Matrix.

Tool What You Can Do with the Tool

Calculation Manager

Create, organize, and manipulate calculations stored by Ecce. Select calculations for use in other Ecce tools, such as the Calculation Editor or Job Launcher.


Build chemical systems to be used in calculations. Visualize, build, modify, and manipulate small molecules in 3D or stereo views. Retrieve and view prebuilt structures from the Ecce Structure Library.

Basis Set Tool

Select predefined Gaussian basis sets or create new ones for use in ab initio electronic structure calculations within Ecce. Access general information on the basis sets stored in the EMSL Gaussian Basis Set Library.

Machine Browser

View an image of your calculation and information about your calculation such as code type, theory/runtype, basis set, setup parameters, and launch information.

Machine Browser

View status and reference information about computers that are registered as Ecce machines. Match computing resources with the job resource requirements of new calculations. Set up machine defaults for running calculations on a specific computer.

Periodic Table

View element reference information, including atomic mass, isotopic abundance, nuclear spins, electronic configuration, and atomic energies.

Online Help

Display the Contents page for Ecce online help in the Netscape web browser.


Send a support request to the Ecce development team about problems, suggestions, questions, and opinions.


Set your preferences for units, colors for calculation states, audible beeps, and other items in the Ecce interface.

Window menu

Access currently active Ecce tools through a pull-down menu located on the right side of the Gateway. The pull-down menu lists the open tool windows.

Where to Get Help

Online help about a specific Ecce tool
Overview of the tool From the tool's Help menu, choose Help on [that tool].
Quick Help about items in an Ecce window 1. Position the mouse cursor over the item.
2. Press the Help key (F1 on SGI and PC keyboards).
If no Quick Help is available for that item, Ecce opens the online help overview of that tool in the Netscape web browser.
Technical Support
How to obtain Ecce software Refer to the Ecce web site Go to Ecce web site.
Problems, suggestions, questions, requests, and opinions addressed to the Ecce development team

EMSL Collaborators:
Please address your email queries or comments to, or use the Support option on the Help menu of any Ecce tool window.

Other users of Ecce at other sites:
Please contact your onsite representative first to see if your need or problem can be resolved. If your site administrator has configured Ecce's tool support option, the Help menu of each tool window contains a Support option for sending email to your onsite representative.

Ecce procedures, training, selection of computing platforms, computational chemistry and computer science consulting

EMSL Collaborators:
Use the web-based MSCF Consulting support request form to request support.
Address email to

Other users of Ecce at other sites:
Please contact your onsite representative first to see if your need or problem can be resolved.

Ecce Online Help
Revised: January 21, 2005